Purple Mash error pages and timeouts
Incident Report for 2Simple Software
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 17:59 GMT
Update
We are continuing to investigate this issue.
Posted Mar 16, 2020 - 17:58 GMT
Update
We are continuing to investigate this issue.
Posted Mar 16, 2020 - 17:39 GMT
Investigating
We are currently investigating this issue.
Posted Mar 16, 2020 - 17:37 GMT
This incident affected: Purple Mash Site.