Slow printing
Incident Report for 2Simple Software
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 21:12 GMT
Investigating
You may find printing files to be extremely slow at the moment in Purple Mash. Apologies - we are working to resolve this issue.
Posted Nov 16, 2022 - 18:07 GMT
This incident affected: Purple Mash Site.