PurpleMash is not responding
Incident Report for 2Simple Software
Resolved
We are continuing to investigate this issue.
Posted Jan 09, 2024 - 13:31 GMT
Update
We are continuing to investigate this issue.
Posted Jan 09, 2024 - 13:30 GMT
Investigating
We are currently investigating this issue.
Posted Jan 09, 2024 - 13:27 GMT
This incident affected: Purple Mash Site.